[Solved] (MAC) Bukkit Server Plugins not working!

Discussion in 'Minecraft Support' started by We Need Emerald Tools, Nov 24, 2012.

Thread Status:
Not open for further replies.
  1. We Need Emerald Tools

    Joined:
    Nov 24, 2012
    Messages:
    1
    Likes Received:
    0
    Hello, I have a problem with my server (I'm Mac 10.5.8). When I run start.command, this pops up when attempting to load Essentials and other plugins:
    [SEVERE] Could not load 'plugins/Essentials.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: Bad version number in .class file
    SEVERE] Could not load 'plugins/Permissions.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: Bad version number in .class file
    [SEVERE] Could not load 'plugins/EssentialsSpawn.jar' in folder 'plugins'
    [SEVERE] Could not load 'plugins/EssentialsProtect.jar' in folder 'plugins'
    [SEVERE] Could not load 'plugins/EssentialsChat.jar' in folder 'plugins'
    [SEVERE] Could not load 'plugins/EssentialsAntiBuild.jar' in folder 'plugins'
    My essentials is up-to-date.
    PLEASE HELP ME!I want my server to be ready before people play on it. :want:
     
    #1 We Need Emerald Tools, Nov 24, 2012
    Last edited by a moderator: Dec 28, 2012
  2. mink13

    mink13 <font color="#cc0000">New Luna Republic</font>

    Joined:
    Nov 28, 2010
    Messages:
    279
    Likes Received:
    11
    I'll look over it, but I don't spent much time with java error logs. I will point our server guru here.
    Edit: Looks like your plugins folder is missing or misplaced. It may be because your server, your plugins, or the program that runs your server is out of date.

    Also: emeralds will not likely become tools, as they are to be money not a second diamond.
     
    #2 mink13, Nov 24, 2012
    Last edited: Nov 24, 2012
  3. CB

    CB Mature Filter for Forums

    Joined:
    Jan 21, 2012
    Messages:
    759
    Likes Received:
    23
    I apologize for not seeing this sooner. Must have gotten lost during my cache clearing.

    The error you're seeing is due to the wrong java file.

    You either need the 32bit or the 64bit. NOT both. If you have both, then please delete both and get the latest version of the one you want to match your server file.

    I.e. if you are running a 64bit OS, with 32bit server.jar file, then you need the 32bit java. If you have a 64bit OS, with 64bit server.jar, then you need the 64bit java. And vise versa for 32bit.

    also, please ensure you have the file loaded into the proper location. If you are in the x86Program Files, it wont work. That is for 32bit support. If you're operating a 64 bit OS, then you need to be using the standard "Program Files" folders.

    Yet still, if you want to get a bit more advanced and use a secondary, mounted hard drive, then you need to mirror and link your java and program file folders to your local c:\ so that it always maps the drive the same way every time.

    Supporting information:
    http://forums.bukkit.org/threads/could-not-load-plugin-for-every-of-my-plugins.86506/

    http://www.minecraftforum.net/topic/1363874-solved-essentials-not-loading/
     
Thread Status:
Not open for further replies.

Share This Page